Artiphp - CMS open source et gratuit
Vous êtes ici » Accueil/Forum
Saisissez votre recherche
RechercherRechercher   Liste des MembresListe des Membres   S'enregistrerS'enregistrer    ProfilProfil 
Se connecter pour vérifier ses messages privésSe connecter pour vérifier ses messages privés   ConnexionConnexion 


Connexion Artiphp4 / phpBB3
Aller à la page Précédente  1, 2, 3, 4, 5, 6, 7, 8, 9  Suivante
 
Poster un nouveau sujet   Répondre au sujet    Artiloo.com Index du Forum -> Scripts et Add ons des membres
Voir le sujet précédent :: Voir le sujet suivant  
Auteur Message
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Dim 13 Jan 2008 17:39    Sujet du message: Répondre en citant

Salut à tous !

Simplement en réinstallant la dernière version je peux maintenant me connecter et me déconnecter sans problème sur artiphp4 et phpBB3. Plus de soucis avec la version de mysql. Merci Jimro

Par contre j'ai un problème avec l'inscription. Dès que j'essaie d'inscrire un nouveau membre il s'affiche un message d'erreur :
-Votre login n'est pas correct (espace ou caractère interdit)
-Ce mail existe déjà... veuillez en choisir un autre
-Les mots de passe (*) sont obligatoires

Or tout est correct ! en modifiant plusieurs fois les données pour tester le même message s'affiche à chaque fois.
D'où peut venir ce soucis ? Est-ce que d'autres l'ont rencontré également ? Merci.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
zonewap



Inscrit le: 29 Aoû 2004
Messages: 149

MessagePosté le: Dim 13 Jan 2008 18:50    Sujet du message: Répondre en citant

Citation:
-Votre login n'est pas correct (espace ou caractère interdit)
-Ce mail existe déjà... veuillez en choisir un autre
-Les mots de passe (*) sont obligatoires


C'est exactement le même problème que j'ai, j'ai donc remis le fichier d'origine functions.php de phpbb et remis à zéro le texte $forumbb="0"; du fichier config.php d'Arti, autrement, plus personne ne peut s'inscrire sur mon site.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Dim 13 Jan 2008 19:21    Sujet du message: Répondre en citant

ah ok.
Apparemment ça fonctionne bien pour sansblog.

Donc on a un problème commun. Juste pour info, est-ce que tu as installé le patch de suppression welcome/index comme moi ? peut-être que ça vient encore de cette modification.

J'essaie de faire des bidouilles dans le fichier inscription.php mais sans succès, toujours ce message d'erreur...
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
zonewap



Inscrit le: 29 Aoû 2004
Messages: 149

MessagePosté le: Dim 13 Jan 2008 19:30    Sujet du message: Répondre en citant

Citation:
est-ce que tu as installé le patch de suppression welcome/index

A cette question, c'est non.

Fab...
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
jimro



Inscrit le: 07 Oct 2004
Messages: 6918

MessagePosté le: Dim 13 Jan 2008 21:31    Sujet du message: Répondre en citant

Argh ! On va y arriver

J'ai fait quelques modifs dans le fichier artilogin.php pour corriger le problème de l'adresse email (Ce mail existe déjà... veuillez en choisir un autre). La donnée se perdait dans les méandres de phpBB3 lors de deux appels successifs au case 'validate' ?!?!
Pour le reste, les nouveaux tests ne montrent pas de problème.

En ce qui concerne les caractères autorisés pour les logins :
- pour Artiphp, uniquement les lettres (minuscules ou majuscules) et les chiffres, pas de caractères spéciaux ; les caractères accentués fonctionnent en principe (pour moi c'est ok), mais je conseille de ne pas les utiliser ; il faut faire attention que le paramétrage de phpBB3 ne vienne pas en contradiction avec ce qui précède.

J'ai mis en ligne l'archive modifiée.


jimro
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Dim 13 Jan 2008 22:43    Sujet du message: Répondre en citant

AaaarrrgghhhhHH ! Suite des tests

avec le nouveau fichier artilogin.php : exactement le même message d'erreur que précédemment. Pourtant caractères en minuscule sans accent,etc.
Je n'ai fait aucun paramétrage particulier dans phpBB3.

Je viens de faire un test en ne changeant qu'un seul fichier, j'ai remis l'ancien fichier inscription.php
Et là surprise ! en tentant une inscription avec les mêmes données que les tentatives précédentes : inscription sans problème sur artiphp et phpBB3, connexion et déconnexion sans problème également depuis artiphp ou phpBB3.

Donc, apparemment y'a un truc qui bloque dans le nouveau fichier inscription.php
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
Sansblog



Inscrit le: 11 Déc 2005
Messages: 129
Localisation: VOSGES

MessagePosté le: Lun 14 Jan 2008 14:32    Sujet du message: Re: Petit bug sur case Rappel Répondre en citant

jimro a écrit:
Sansblog a écrit:
Peut être parceque j'ai mis le patch anti déconnexion sur XXL4.

Ah oui, à ce sujet, pourrais-tu nous redonner la marche à suivre et les modifs à faire. Je n'ai jamais eu l'occasion de le tester et je ne le retrouve plus.


jimro


Oui: consulter ce message:
http://www.artiloo.com/phpBB2/viewtopic.php?t=8241&highlight=

Ce patch marche très bien.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé
ivoyages



Inscrit le: 03 Jan 2004
Messages: 1522

MessagePosté le: Lun 14 Jan 2008 16:02    Sujet du message: Répondre en citant

Bonjour,

Je souhaite installer mon premier forum. J'ai installé le patch Wolcome/index et ça semble plutôt compliqué à modifier. Quelqu'un a t-il réussi à réécrire les fichiers ?

Greg
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
Sansblog



Inscrit le: 11 Déc 2005
Messages: 129
Localisation: VOSGES

MessagePosté le: Lun 14 Jan 2008 19:23    Sujet du message: Répondre en citant

eric83 a écrit:
ah ok.
Apparemment ça fonctionne bien pour sansblog.

Donc on a un problème commun. Juste pour info, est-ce que tu as installé le patch de suppression welcome/index comme moi ? peut-être que ça vient encore de cette modification.

J'essaie de faire des bidouilles dans le fichier inscription.php mais sans succès, toujours ce message d'erreur...

En lisant ces messages, j'ai réessayé et effectivement, personne ne peut créer de nouveau compte.

Ce qui avait marché, c'était un utilisateur que j'avais créé mais qui n'avait pas de compte sur le forum -> son compte a été créé sur phpBB3.

J'en avais conclu un peu vite que tout marchait ...
et j'ai toujours le bug de la case rappel - en fait, si je vais sur le site sans me loguer, et que je vais sur phpBB3, alors je suis enregistré admin ( login automatique de firefox)
Donc la case rappel ne doit toujours pas être cochée chez moi.
Et personne ne peut se créer un compte.

Désolé de vous avoir induits en erreur: je testerai TOUT avant d'affirmer le fonctionnement d'un module/script.

Mes derniers fichiers utilisés sont ceux de l'archive du 13 01 08 de Jimro.

Didier.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé
jimro



Inscrit le: 07 Oct 2004
Messages: 6918

MessagePosté le: Lun 14 Jan 2008 20:25    Sujet du message: Répondre en citant

Tout ça est bizarre : différence de versions, de configuration ?!?!

eric83 a écrit:
Je n'ai fait aucun paramétrage particulier dans phpBB3.

Moi non plus.

Citation:
Je viens de faire un test en ne changeant qu'un seul fichier, j'ai remis l'ancien fichier inscription.php
...
Donc, apparemment y'a un truc qui bloque dans le nouveau fichier inscription.php

Pas forcément, je pense plutôt que le problème se situe au niveau du case 'validate' dans artilogin.php, ou pour être plus précis à l'appel répété d'artilogin.php depuis inscription.php pour ce "case 'validate'". Pour le confirmer, si tu en as la possibilité, essaie ceci :
- dans inscription.php vers la ligne 183, mets en commentaire le code suivant comme ceci :
Code:
/*
      if (!defined('IN_ARTI')) {
         define('IN_ARTI', true);
      }

      $mode = 'validate';
      $retour_arti = false;

        $username = $login;
        require($cheminphpBB . '/artilogin.php');

        if ($valid_username == 0) {
            $attention_login = '2';
        }
*/

- si le problème est toujours présent, enlève les commentaires que tu viens de mettre( /* et */ ), et vers la ligne 221, procède de la même manière pour ce code :
Code:
/*
      if (!defined('IN_ARTI')) {
         define('IN_ARTI', true);
      }

      $mode = 'validate';
      $retour_arti = false;

        $user_email = $mail;
        include($cheminphpBB . '/artilogin.php');

        if ($valid_email == 0) {
            $attention_mail = '2';
        }
*/

- si ça ne convient toujours pas, laisse le commentaire sur le contrôle de validité de l'adresse de courriel, et remets le commentaire sur le contrôle de validité du login (mentionné plus haut).

Autre test envisageable : sans rien toucher aux fichiers du 13/01/2008, dans le paramétrage de phpBB3, supprimer la vérification du domaine MX pour les adresses email (panneau d'administration, onglet GENERAL, Paramètres de sécurité -> "Vérifier l’e-mail pour un enregistrement MX valide". Pour ma part, ça fonctionne bien que cette vérification soit ou non activée.


Sansblog a écrit:
Oui: consulter ce message:
http://www.artiloo.com/phpBB2/viewtopic.php?t=8241

Merci, mais je faisais plutôt allusion à la méthode donnée par Artiloo avec une modif au niveau de la gestion des sessions (genre 1 ou 2 lignes à ajouter à un ou des endroits clés). Ce message d'Artiloo a dû être supprimé, je ne le retrouve plus.


Sansblog a écrit:
En lisant ces messages, j'ai réessayé et effectivement, personne ne peut créer de nouveau compte.

Ce qui avait marché, c'était un utilisateur que j'avais créé mais qui n'avait pas de compte sur le forum -> son compte a été créé sur phpBB3.

J'en avais conclu un peu vite que tout marchait ...
et j'ai toujours le bug de la case rappel - en fait, si je vais sur le site sans me loguer, et que je vais sur phpBB3, alors je suis enregistré admin ( login automatique de firefox)
Donc la case rappel ne doit toujours pas être cochée chez moi.
Et personne ne peut se créer un compte.

Tous ces aspects fonctionnent parfaitement chez moi !?!?


Essayez de donner quelques précisions sur votre configuration. En ce qui me concerne :
- Apache 1.3.27
- PHP 4.3.11
- MySQL 4.1.16
- base de données Artiphp : interclassement latin1_general_ci
- tables phpBB3 : interclassement utf8_bin
- ...


jimro
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Mar 15 Jan 2008 0:28    Sujet du message: Répondre en citant

Alors, suite des tests :

J'ai tenté les manips que tu donnes mais sans succès.

La page d'inscription s'affiche mais le résultat en tentant une inscription :
- Votre login n'est pas correct (espace ou caractère interdit)
- Ce mail existe déjà... veuillez en choisir un autre
- Les mots de passe (*) sont obligatoires
=> Problème toujours présent.

Nouveau test :
En mettant en commentaire toutes les parties que tu mentionnes et bien... CA FONCTIONNE !!!
Inscription, connexion et déconnexion dans les deux sens.


Citation:
Je souhaite installer mon premier forum. J'ai installé le patch Welcome/index et ça semble plutôt compliqué à modifier. Quelqu'un a t-il réussi à réécrire les fichiers ?
Greg

Et bien en définitive je n'ai rien modifié. J'ai juste installé la dernière version du module artilogin proposé par jimro et ça fonctionne très bien en mettant en commentaire les portions de code mentionnées plus haut. Test réalisé avec succès à l'instant
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
ivoyages



Inscrit le: 03 Jan 2004
Messages: 1522

MessagePosté le: Mar 15 Jan 2008 8:36    Sujet du message: Répondre en citant

eric83 a écrit:
e patch Welcome/index et ça semble plutôt compliqué à modifier. Quelqu'un a t-il réussi à réécrire les fichiers ?
Greg

Et bien en définitive je n'ai rien modifié. J'ai juste installé la dernière version du module artilogin proposé par jimro et ça fonctionne très bien en mettant en commentaire les portions de code mentionnées plus haut. Test réalisé avec succès à l'instant [/quote]

Merci pour l'info... Ce qui coince est ailleurs selon tes posts et les autres

Greg
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
Sansblog



Inscrit le: 11 Déc 2005
Messages: 129
Localisation: VOSGES

MessagePosté le: Mar 15 Jan 2008 16:07    Sujet du message: Création compte Ok pour moi aussi Répondre en citant

Bonjour à tous.

J'ai commenté les deux portions de code mentionnées par Jimro.
La création de compte fonctionne désormais.


Reste chez moi le bug de la case rappel qui ne me logue pas sur le forum si elle est cochée.
Je vais regarder le patch anti déconnexion qui agit si cette case est cochée (il n'a l'air d'agir que depuis la zone d'administration mais je vais approfondir)

Fichiers: Version du 13/01/2008 de Jimro.
Mysql: 5.0.32
Langage: french iso-8859-1
Chez OVH
Je ne trouve pas leur version apache ni celle de leur moteur php.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé
Sansblog



Inscrit le: 11 Déc 2005
Messages: 129
Localisation: VOSGES

MessagePosté le: Mar 15 Jan 2008 16:20    Sujet du message: Re: Création compte Ok pour moi aussi Répondre en citant

Sansblog a écrit:

J'ai commenté les deux portions de code mentionnées par Jimro.
La création de compte fonctionne désormais.
php.

Parceque si je ne commente que la 1ère partie ou que la 2ème, on ne peut toujours pas créer de nouveau compte.
Les deux modifs sont nécéssaires.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé
jimro



Inscrit le: 07 Oct 2004
Messages: 6918

MessagePosté le: Mar 15 Jan 2008 21:19    Sujet du message: Répondre en citant

A la suite de nouveaux tests, sur une config plus récente (MySQL 5.0.27, PHP 5.2.0 et Apache 2), de nouveaux problèmes sont apparus et donc de nouvelles modifications et corrections :
- incompatibilité de la requête INSERT d'origine dans welcome/inscription.php avec MySQL 5
- erreur dans welcome/changemail.php
- modification du code dans artilogin.php concernant le contrôle de l'email (fonction phpBB3 validate_email() non utilisée car phpbb_checkdnsrr() provoque parfois des résultats inattendus, en particulier sur quelques serveurs d'hébergement Windows si le contrôle du domaine de courriel est activé dans phpBB3)

Tout fonctionne correctement avec les versions mentionnées ci-dessus.
Je ne pourrais pas malheureusement tester cet add-on sur toutes les configs


La nouvelle archive du 15/01/2008 est téléchargeable via le même lien.


Merci aux testeurs
jimro

PS : Le contrôle du login et de l'adresse email pour Artiphp et phpBB manquait jusque là (avec phpBB2) au niveau de l'inscription. Il est important que ça fonctionne pour rester cohérent avec le reste.
D'ailleurs, je n'ai pas vu de retour de test sur les modifications de profil (login et adresse de courriel)
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Artiloo.com Index du Forum -> Scripts et Add ons des membres Toutes les heures sont au format GMT + 1 Heure
Aller à la page Précédente  1, 2, 3, 4, 5, 6, 7, 8, 9  Suivante
Page 2 sur 9

 
Sauter vers:  
Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum


Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com