Artiphp - CMS open source et gratuit
Vous êtes ici » Accueil/Forum
Saisissez votre recherche
RechercherRechercher   Liste des MembresListe des Membres   S'enregistrerS'enregistrer    ProfilProfil 
Se connecter pour vérifier ses messages privésSe connecter pour vérifier ses messages privés   ConnexionConnexion 


[réglé arti4 et arti5] La Médiathèque ne fonctionne plus!
Aller à la page 1, 2, 3, 4, 5  Suivante
 
Poster un nouveau sujet   Répondre au sujet    Artiloo.com Index du Forum -> Le coin des testeurs
Voir le sujet précédent :: Voir le sujet suivant  
Auteur Message
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Mer 19 Aoû 2009 13:19    Sujet du message: [réglé arti4 et arti5] La Médiathèque ne fonctionne plus! Répondre en citant

Bonjour,

Je viens de m'apercevoir que plus aucun article ne s'affiche dans la médiathèque. Même en utilisant le moteur de recherche du module.

Mais j'ai l'impression que ça vient d'amazon car je viens de vérifier sur mon site en ligne sous xxl4 et même problème!

J'ai aussi fait une vérification à partir d'un site d'artiloo "artiquoti" avec le même résultat...
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
ivoyages



Inscrit le: 03 Jan 2004
Messages: 1522

MessagePosté le: Ven 21 Aoû 2009 12:53    Sujet du message: Répondre en citant

Je confirme et le moteur de recherche est hs aussi

Greg
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Lun 24 Aoû 2009 22:25    Sujet du message: Répondre en citant

Bonsoir,

Dites c'est inquiétant ça fait une semaine que le module médiathèque ne fonctionne plus du tout (enfin une semaine que je m'en suis rendu compte!)

J'espère que Amazon n'a pas modifié ses services aux développeurs, rendant ainsi inutilisable le module...
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
zeia



Inscrit le: 18 Déc 2004
Messages: 218
Localisation: toulouse

MessagePosté le: Mer 26 Aoû 2009 22:23    Sujet du message: Répondre en citant

Salut

effectivement amazon a legerement modifié ses service,

voici un mail que j'avais reçus fin juillet :

Citation:
Cher développeurs,

Vous avez reçu une notification concernant la demande d'authentification des requêtes sur notre plateforme Product Advertising API. Vous avez déjà pris en compte cette demande d'authentification ou êtes en phase d'intégration, et nous souhaitons vous remercier de votre collaboration.

Lors des mises à jour de la précédente version de la plateforme Product Advertising API en 2008, nous avions mis en place un planning de test des nouvelles fonctions. Cela nous a également permis de souligner à votre égard les modifications apportées. Et parce que nous avons reçu des retours positifs de notre communauté de développeurs en réponse à la mise en place de ce planning, nous avons décidé de mettre en place le même type de calendrier avant l'échéance du 15 août 2009. La période de tests vous permet d'assurer la mise en place des demandes authentifiées, qui seront obligatoires à partir du 15 août 2009. Veuillez notez les dates et horaires ci-dessous :

PERIODE 1 : UNE requête non authentifiée sur CINQ (sélectionnée au hasard) sera rejetée.

- Toutes régions confondues (NA, EU, JP) lundi 3 août 2009, 18h00 GMT/UTC, test d'une durée de 24h (correspond à 11h00 PDT et 3h00 JST)

PERIODE 2 : TOUTES les requêtes non authentifiées seront rejetées à partir de ces dates :

- EUROPE (UK, DE, FR) : lundi 10 août 2009, de 14h00 à 16h00 GMT/UTC.

- AMERIQUE DU NORD (US & CA) lundi 10 août 2009, de 18h00 à 20h00 GMT/UTC.

- JAPON (JP) : mardi 11 août 2009, de 13h00 à 15h00 GMT/UTC.

Ce planning de test de requêtes authentifiées de la plateforme Product Advertising API vous permet de tester la mise en place de ces nouvelles requêtes dans vos outils et de découvrir aussitôt les implémentations et codes qui auraient pu être oubliés. Cela vous donne également l'opportunité d'inclure ces modifications avant l'échéance du 15 août 2009.

Durant cette période, si vos requêtes à la plateforme Product Adertising API venaient à être rejetées, assurez-vous alors que celles-ci soient correctement authentifiées. Les requêtes correctement authentifiées ne seront pas affectées durant les périodes citées ci-dessus.

Nous souhaitons profiter de cette opportunité pour vous souligner les outils mis à votre disposition afin de vous aider à réaliser ce changement dans vos applications :


Le Developer Guide contient tous les détails dont vous avez besoin pour comprendre ce que sont les requêtes authentifiées et comment les construire.
Des exemples de code (Sample Code) pour des requêtes authentifiées sont disponibles dans l’environnement Java, C# et Perl.
Notre Forum (Community Forums)où notre équipe technique, accompagnée des autres développeurs, peut répondre à vos questions.
D’autres outils sont disponibles sur la page d’accueil de l’interface Product Advertising API.
Nous vous remercions pour la mise en avant des produits Amazon et nous espérons partager encore pour longtemps les revenus générés par ces ventes.
L'équipe Product Advertising API.


a priori, maintenant chaque requêtes doit être authentifiées

@+^^
zeia
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Ven 28 Aoû 2009 14:29    Sujet du message: Répondre en citant

Salut zeia,

Je n'ai pas vu ce mail mais ça confirme bien mes doutes...

J'espère qu'artiloo va être moins surbooké pour nous proposer une adaptation avec ces nouvelles requêtes dites authentifiées...

Un correctif pour nos sites en ligne avec xxl4 serait franchement le bienvenue (en attendant xxl5)

@+
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
ivoyages



Inscrit le: 03 Jan 2004
Messages: 1522

MessagePosté le: Ven 28 Aoû 2009 14:44    Sujet du message: Répondre en citant

Même avis
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
artiloo



Inscrit le: 15 Avr 2002
Messages: 4678
Localisation: Cholet (Maine et Loire)

MessagePosté le: Lun 31 Aoû 2009 8:23    Sujet du message: Répondre en citant

Salut,
Effectivement amazon a changé son API et depuis le 15 aout ca ne fonctionne plus.

Je vois ca le plus rapidement possible (c'est ma priorité) pour Arti 4 et 5.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
artiloo



Inscrit le: 15 Avr 2002
Messages: 4678
Localisation: Cholet (Maine et Loire)

MessagePosté le: Lun 31 Aoû 2009 17:10    Sujet du message: Répondre en citant

HE Bien, quelle galère cette nouvelle version de l'API Amazon...

Après une journée à essayer de comprendre le fonctionnement de leur nouvel API, et notamment la signature, je crois que je tiens le bon bout...
Mes derniers tests fonctionnent et j'affiche enfin le fichier xml.

Il faut que j'implante ça sur chaque fichier du répertoire... Je vous tiens au courant demain soir.
Pour une reprise, c'est une reprise... J'ai déjà plus beaucoup de cheveux
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
artiloo



Inscrit le: 15 Avr 2002
Messages: 4678
Localisation: Cholet (Maine et Loire)

MessagePosté le: Lun 31 Aoû 2009 20:23    Sujet du message: Répondre en citant

Ok, je viens de refaire la version d'artiAmazon 4.0.4 pour Artiphp 4.

C'est déjà un bon début.

Je vais m'atteler demain à la version pour Artiphp 5
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Lun 31 Aoû 2009 22:12    Sujet du message: Répondre en citant

Salut artiloo,

Content de voir que tu es de retour de tes grandes vacances

Dès que la version d'artiAmazon pour xxl5 est prête met là aussitôt sur le dépôt SVN, on se fera un plaisir de continuer les tests.

La todo-list t'attend...

@+

Edit: merci pour la version du module sous xxl4 je viens de voir qu'elle était dans la rubrique téléchargement.
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
artiloo



Inscrit le: 15 Avr 2002
Messages: 4678
Localisation: Cholet (Maine et Loire)

MessagePosté le: Lun 31 Aoû 2009 22:55    Sujet du message: Répondre en citant

Eric83,

J'ai mis les fichiers de la V.5 sur le depot... Je n'ai pas testé, mais ca devrait fonctionner.

Peux tu faire un test ?
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Lun 31 Aoû 2009 23:06    Sujet du message: Répondre en citant

Bonsoir artiloo,

Ok, je m'occupe de tester tout ça!
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Mar 01 Sep 2009 2:54    Sujet du message: Répondre en citant

Bonjour,

Bon et bien je n'arrive pas à faire fonctionner le module ni sous la v4 ni sous la v5...

Mais j'ai peut-être fait des bêtises. Je ne trouvais plus mon mot de pass pour le webservice et j'ai recréé un compte pour pouvoir avoir les 2 codes (key perso et secret key perso) maintenant nécessaires.

Je les ai bien renseigné:
Sur le fichier code_perso.php de la v4
Et depuis la zone d'admin de la v5
Sans oublier le tag-perso

Mais les requêtes ne sont toujours pas validées et rien ne s'affiche...

Il va falloir que d'autres testeurs confirment s'il y a un soucis ou si c'est moi qui fait des boulettes... (mais bon si toi tu arrives à le faire fonctionner!)

En attendant je vais continuer à tester.


Pour la v5 il y a une erreur qui empêche de charger la page modif_personnalisation.php au niveau de la ligne 84, il manque des slashes:
Citation:
$texte4 .= "\$num_php=\"" . $num_php . "\"; //version de php : pour php4 num_php=\"4\" et pour php5 num_php=\"5\"\n";
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
artiloo



Inscrit le: 15 Avr 2002
Messages: 4678
Localisation: Cholet (Maine et Loire)

MessagePosté le: Mar 01 Sep 2009 8:02    Sujet du message: Répondre en citant

Salut,
Tu as quelle version de php ?

Sur artiloo.com, j'ai une version 4
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
eric83



Inscrit le: 17 Sep 2005
Messages: 595
Localisation: Garéoult (Var)

MessagePosté le: Mar 01 Sep 2009 16:50    Sujet du message: Répondre en citant

J'ai php4 aussi.
J'ai quand même testé également en mettant 5 pour voir si dès fois ça marchait mais non page blanche

Je ne comprends pourquoi ça ne fonctionne pas chez moi.

Ce serait bien d'avoir d'autres retours des artinautes testeurs...
Revenir en haut de page
Voir le profil de l'utilisateur Envoyer un message privé Visiter le site web de l'utilisateur
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Artiloo.com Index du Forum -> Le coin des testeurs Toutes les heures sont au format GMT + 1 Heure
Aller à la page 1, 2, 3, 4, 5  Suivante
Page 1 sur 5

 
Sauter vers:  
Vous ne pouvez pas poster de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas voter dans les sondages de ce forum


Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com